PDA

Ver Versão Completa : Steam + Beta patchs



nigo
01/09/2008, 14:11
para quem tem o CoH no steam e quer tentar os beta patchs

arquivos necessarios e duvidas podem ser encontrados no link original

http://forums.relicnews.com/showthread.php?t=194838&page=1




My friend and I were both able to work the beta on coh. Some minor mishaps, but here's how it works!

Using the method described by that smart guy at gamereplays for the team automatch beta here, (http://www.gamereplays.org/community/index.php?showtopic=330684&st=0&p=3990925&#entry3990925) the steam version can be used.

Download the cohsteambeta.txt file at the bottom of the page and open it. Replace install path with YOUR version of coh on steam. It should be similar to what mine has. Be sure to use 2 slashes for seperate folders (like this \\) since apparently thats how windows registry works. I think display icon doesn't matter but just keep it the same as install path and add reliccoh.exe to the end of it.

Rename the cohsteambeta.txt to cohsteambeta.reg, then merge it (ie run it) say yes and then attempt to run your installer.

Now attempting to run the installer should say reliccoh.english.ucs isn't messed up. I had my friend (who has the CD version of coh) give me his reliccoh.english.ucs file, which i replaced my file with, which I then had steam reverify (since just replacing these files will cause steam to stop working)

The file can be found here. (http://www.mediafire.com/?lfutbxyj9zx)

I was unable to upload it, since it's a UCS file. Make a back up copy of your reliccoh.english.ucs file and replace it with that file. It's located in your coh folder under engine/locale/english.

Now run the installer. Everything should go smoothly and finish.

You can change your reliccoh.english.ucs file back afterwards if you want.

PROBLEMS YOU MIGHT HAVE:

If you've changed anything such as bindings or such, you could run in to problems.

With me and my friend, we had problems with our username and password logging in. Erase your user name and retype it, as well as your password. Or you might not have a problem with this. If you can't log in though, thats how to fix it.

If it continues to say your password is incorrect, just change it. Your CD keys is accessible by going to create new account. You'll have to know your security question.

Error verifying media was fixed by restarting the coh beta, or by running the steam version of coh and then running the beta. Not sure which fixed it, but shots in the dark.

MAKE SURE YOU CHANGE YOUR GRAPHICS SETTINGS. Mine went back to ultra high default and I couldn't even start a round because of the lag.

Good luck! Oh yeah, you do this at your own risk, yadda yadda. Be careful!

_____________________________________________

By usefuljon:

Reminder this is for XP x64 ONLY I didn't test it on vista so do at your own risk.

Now I expect this will only be useful for about 2 people besides me but here it is anyways.

First, copy this and past it into a .txt file. Save the file then rename it as a .reg. Double click and it will ask if you're sure say yes. There now your computer thinks it has CoH installed.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\ Windows\CurrentVersion\Uninstall\Company of Heroes]
"DisplayName"="Company of Heroes"
"UninstallString"="\"doesnotmatter\""
"InstallLocation"="C:\\Program Files (x86)\\Steam\\steamapps\\common\\company of heroes"
"Publisher"="THQ Inc."
"DisplayVersion"="2.301.0"
"DisplayIcon"="\"C:\\Program Files (x86)\\Steam\\steamapps\\common\\company of heroes\\reliccoh.exe\"


Once you've done this run the beta installer.
I tried to be nice and include an "interforum" link but the damn software wouldn't let me. It's sticked at the top of this forum I'll trust you can find it.

After it completes you will need to download every patch manually. Also sticked at the top of this forum

For some reason it won't auto download, at least it didn't for me. There are currently 8 patches so it will take awhile. They have to be installed sequentially you can't just install the latest one.

Once you have installed all 8 patches start the game put in your account details and presto you're done.

All of this is a modification of the XP 32bit version for Steam. I just figured out where x64 wanted the registry entries to be.

Yay for steam users!